Azure DNS issues
Incident Report for Check21.com
Resolved
Microsoft has resolved the incident by moving its services to a different DNS server. All systems are operational.
Posted Apr 02, 2021 - 02:25 UTC
Update
DNS issue impacting multiple Microsoft services - Mitigated (Tracking ID GVY5-TZZ)

Summary of Impact: Between approximately 21:30 UTC and 22:30 UTC on 01 Apr 2021, customers may have experienced intermittent issues accessing Microsoft services, including Azure, Dynamics, and Xbox Live.

Preliminary Root Cause: We are continuing to investigate the underlying cause for the DNS outage but we have observed that Microsoft DNS servers saw a spike in DNS traffic.

Mitigation: Microsoft engaged resilient DNS capabilities to absorb the spike in DNS traffic.

Next Steps: We apologize for the impact caused by this outage. We are continuing to investigate to establish the full root cause.
Posted Apr 02, 2021 - 01:41 UTC
Update
Warning DNS issue impacting multiple Microsoft services - Validating recovery

SUMMARY OF IMPACT: Starting at approximately 21:30 UTC on 01 Apr 2021, customers may experience intermittent issues accessing Microsoft services, including Azure, Dynamics, and Xbox Live.


CURRENT STATUS: We have confirmed that the underlying DNS outage has been mitigated. Currently we are validating the recovery of the downstream services called out here on the status page. We will be providing a preliminary root cause and additional details within 30 minutes.

This message was last updated at 23:54 UTC on 01 April 2021
Posted Apr 01, 2021 - 23:59 UTC
Update
DNS issue impacting multiple Microsoft services - Recovery in progress

SUMMARY OF IMPACT: Starting at approximately 21:30 UTC on 01 Apr 2021, customers may experience intermittent issues accessing Microsoft services, including Azure, Dynamics, and Xbox Live.


CURRENT STATUS: Microsoft rerouted traffic to our resilient DNS capabilities and are seeing improvement in service availability. We are continuing to investigate the cause of the DNS issue. The next update will be provided in 30 minutes or as events warrant.

This message was last updated at 22:36 UTC on 01 April 2021
Posted Apr 01, 2021 - 22:47 UTC
Investigating
Warning DNS issue impacting multiple Microsoft services - Investigating

SUMMARY OF IMPACT: Starting at approximately 21:30 UTC on 01 Apr 2021, a subset of customers may experience intermittent issues accessing Microsoft services, including Azure, Dynamics, and Xbox Live.

CURRENT STATUS: Engineering teams have been engaged and are currently investigating a potential underlying DNS issue. The next update will be provided in 60 minutes or as events warrant.

This message was last updated at 22:12 UTC on 01 April 2021
Posted Apr 01, 2021 - 22:16 UTC
This incident affected: Check21.com Payment Gateway APIs (Check21.com Payment Submission API, Check21.com Payment and Customer Update API, Check21.com Payment Status Verification API) and Management Portal, Image Processing APIs, CheckVerification.com Verification Gateway APIs.